UZI Talk Forums
+ Reply to Thread
Results 1 to 6 of 6

Thread: What would make an auto AK not function properly in semi auto only?

  1. #1
    Registered User bruh44's Avatar
    Join Date
    Jan 2004
    Location
    NC
    Posts
    827

    What would make an auto AK not function properly in semi auto only?

    Iíve got a Valmet M-78 in 7.62x39 that I just got back with a new barrel on it. Auto is great. It will fire one, maybe two rounds. The next gets locked in the chamber with a light strike. The chamber is very difficult to open when this happens. Is this a worn out fire control group? Springs? Any other ideas?

  2. #2
    UZI Talk Supporter

    Join Date
    Oct 2014
    Posts
    162
    almost sounds like hammer follow...

  3. #3
    UZI Talk Supporter
    sniperdoc's Avatar
    Join Date
    Jan 2015
    Location
    TN
    Posts
    5,099
    Although highly unlikely in a Valmet, I had a Maadi semi auto that had an almost identical problem; the front trunnion was out of spec and the bolt was binding.

  4. #4
    Registered User DINK's Avatar
    Join Date
    Dec 2005
    Location
    CT
    Posts
    480
    Since it just got rebarreled and you describe it as being very hard to open when a round fails to go off, my guess would be insufficient headspace. The bolt is barely closing in most cases and an occasional round is long enough to really lock things up.

  5. #5
    Registered User bruh44's Avatar
    Join Date
    Jan 2004
    Location
    NC
    Posts
    827
    Either way, I’m sure I’m going to have to bring it back to the guy that did the barrel. I was just hoping it was something simple I could do. But it didn’t have this problem before the barrel got replaced. It does run 100% in auto.

  6. #6
    Registered User OldBesty's Avatar
    Join Date
    Oct 2018
    Location
    Wesley Chapel, FL
    Posts
    731
    Since you're an MG guy, there's good chance you haven't cleaned it yet...it could simply be due to the accumulation of fouling over the tighter tolerances of new barrel chamber from running FA, enough so that is preventing it running SA correctly.

    Did you check appearance of the casings, particularly the stuck ones (they cay indicate if surface irregularities inside the chamber)? Have you gotten good look at the chamber? It could be needing light sanding and/or a good polishing job depending what you see.

    Remember to inspect your spare barrels too. If headspace is excessively tight, might need to have them reamed.

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts


Please consider becoming an UZI Talk Supporter.